`gem rdoc --all` should ignore .gemrc setting of `gem: --no-ri --no-rdoc`

mikbe.tk's Avatar

mikbe.tk

24 Mar, 2011 01:05 AM

Previously you could run gem rdoc --all and it would ignore the no doc settings in your .gemrc file (gem: --no-ri --no-rdoc). This is no longer the case. Hopefully this wasn't a design decision.

Calling gem rdoc --all is explicitly saying, "I want to install the docs for all my gems." so should override the .gemrc file setting.

It's incredibly useful to be able to disable the painfully slow documentation generation process and then run it manually so I beg of you, please re-enable this functionality.

Thank you.

  1. Support Staff 2 Posted by Nick Quaranto on 27 May, 2011 12:30 AM

    Nick Quaranto's Avatar

    What version of RG/rdoc is this happening for you with? First I've heard of this.

  2. 3 Posted by mikbe.tk on 27 May, 2011 04:16 AM

    mikbe.tk's Avatar

    Thanks for the reply. I'm not sure if you mean it's always done this or it shouldn't do this but you've not heard about it.

    I installed older versions of both Ruby Gems and rdoc and I couldn't get it to replicate the behavior I thought it was doing previously so I must have been wrong. Sorry for the bad report.

    I do stil think it should ignore the no doc line when running gem rdoc --all but it's not reasonable for me to ask for you to change the way it's been working and is expected to work by others. Maybe a --force-all option could be added but I also realize there are more important things on your plate.

    Thank you again for your time and sorry to have wasted it. And thanks for all the work all of you do for free to support the community!

    P.S. I'm not sure if I'm supposed to close this or you are...

  3. mikbe.tk closed this discussion on 06 Jun, 2011 07:47 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

29 Aug, 2014 06:23 PM
28 Aug, 2014 07:18 PM
27 Aug, 2014 12:03 PM
26 Aug, 2014 07:09 PM
26 Aug, 2014 07:07 PM