Difficulty with Rubygems.com site

Jay Shepherd's Avatar

Jay Shepherd

14 Jan, 2011 09:24 PM

For the two days, I have had problems connecting to the Rubygems.com site. I am having intermittent problems connecting to the home page, sign-in, sign-up (at least) I was just able to attempt a log-in, but then got an Error 102 (net::ERR_CONNECTION_REFUSED): Unknown error. Also when trying to add a gem, I get a connection refused error. I've tried with FireFox, Chrome, Safari with different results. I can't think of anything that would cause it from my end, and am not having similar issues with other sites.

I just went straight to www.rubygems.org with Safari, got the home page. Clicked "all gems" and got a list, Clicked "sign in", got Safari can’t connect to the server (not sure what the http code is, went back, refreshed, got list of gems again, clicked "sign up", got Safari can’t connect to the server.

Let me know if you need more info or have questions.

  1. 2 Posted by Jay Shepherd on 14 Jan, 2011 09:25 PM

    Jay Shepherd's Avatar

    erg... I mean rubygems.org, not .com and I get the same experience starting with the gemcutter.org name (which gets changed to rubygems.org)

  2. 3 Posted by Jay Shepherd on 18 Jan, 2011 03:27 AM

    Jay Shepherd's Avatar

    Just reset my router configs and am trying to eliminate DNS on my end, but still having the same issues. Perhaps it's an SSL problem? I still can go to some pages OK with http, but not https, such as log in or sign up.

  3. Support Staff 4 Posted by Nick Quaranto on 18 Jan, 2011 04:05 AM

    Nick Quaranto's Avatar

    I think we would hear a lot of noise on twitter and a lot of yelling if people couldn't get to the site. I think it's your router, ISP, or firewall/proxy setup. Any ideas about that? Can yo provide a traceroute? Does gem list -r work? Added our sysadmin Tom to this conversation as well if he has any ideas.

  4. Support Staff 5 Posted by Tom Copeland on 18 Jan, 2011 03:24 PM

    Tom Copeland's Avatar

    Hm, yeah, on this end our NewRelic graphs don't show any downtime for the past few weeks... just ticking along at 50-60 requests/second.

  5. 6 Posted by Jay Shepherd on 18 Jan, 2011 09:57 PM

    Jay Shepherd's Avatar

    Well, it worked just now. Go figure!

  6. Support Staff 7 Posted by Tom Copeland on 18 Jan, 2011 10:19 PM

    Tom Copeland's Avatar

    That's the internets for ya.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac