Empty dependecies

Masahiro Nakagawa's Avatar

Masahiro Nakagawa

08 Apr, 2013 12:08 PM

Hi guys,

Today, we hit the problem that some latest gems return empty dependencies.
For example, fluent-mixin-config-placeholders (https://github.com/tagomoris/fluent-mixin-config-placeholders)

Marshal.load(open("http://rubygems.org/api/v1/dependencies?gems=fluent-mixin-config-pl...) => [{:dependencies=>[], :platform=>"ruby", :number=>"0.2.1", :name=>"fluent-mixin-config-placeholders"}, {:dependencies=>[], :platform=>"ruby", :number=>"0.2.0", :name=>"fluent-mixin-config-placeholders"}, {:dependencies=>[["fluentd", ">= 0"], ["uuidtools", ">= 0"]], :platform=>"ruby", :number=>"0.1.0", :name=>"fluent-mixin-config-placeholders"}]

fluent-plugin-webhdfs (https://github.com/fluent/fluent-plugin-webhdfs) also has same problem.
This problem causes lack of gems in "bundle install"

Do you see any problem? How to fix?

Thanks,
Masahiro

  1. 1 Posted by tagomoris on 08 Apr, 2013 01:18 PM

    tagomoris's Avatar

    I found that gems are in this trouble with specs like below:
    * same dependencies are in "add_development_dependecy" and "add_runtime_dependency"

    And this trouble seems only with gems and/or versions that released this few months.

  2. Support Staff 2 Posted by Nick Quaranto on 08 May, 2013 12:17 AM

    Nick Quaranto's Avatar

    Looks like a problem with bundler-api...which isn't fully in rubygems.org. If this is still happening please report it to:

    http://github.com/rubygems/bundler-api

  3. Nick Quaranto closed this discussion on 08 May, 2013 12:17 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

30 Oct, 2014 04:34 PM
30 Oct, 2014 02:46 PM
28 Oct, 2014 09:51 AM
23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM