Binaries installed with Rubygems not found

Philipp Lange's Avatar

Philipp Lange

01 Nov, 2010 06:06 PM

When I try to run binaries installed with "gem" (for example rdoc), it says the program is currently not installed.
I'm running Linux Mint, and everything Ruby-related was installed through apt-get/Aptitude. Ruby version 1.9.1 plus the bundled Rubygems.

  1. Support Staff 1 Posted by Nick Quaranto on 02 Nov, 2010 11:02 PM

    Nick Quaranto's Avatar

    Hi there,

    That definitely seems strange, perhaps they're not on your PATH? What gems did you try to install? Can you paste your gem env ?

  2. 2 Posted by Philipp Lange on 03 Nov, 2010 11:58 AM

    Philipp Lange's Avatar

    ...in the meanwhile, I found out that there are just some problems with Debian-related distros; a manual installation from source of gem solved it. Thank you anyways!

  3. 3 Posted by Philipp Lange on 03 Nov, 2010 12:15 PM

    Philipp Lange's Avatar

    I found out what the problem was; the 1.9.* package of Ruby apparently contains a flawed version of RubyGems, with some custom_require.rb removed or something. A manual reinstallation of RubyGems from source fixed everything.

    Thank you anyways!

  4. 4 Posted by Philipp Lange on 03 Nov, 2010 12:29 PM

    Philipp Lange's Avatar

    I found and fixed the problem in the meantime;
    Apparently, the Ruby package I downloaded lacks one file (custom_require.rb) that makes the whole thing go to hell. I manually reinstalled RubyGems from source, and everything works now.

    Thank you anyways!

  5. Support Staff 5 Posted by Nick Quaranto on 05 Nov, 2010 01:13 AM

    Nick Quaranto's Avatar

    Glad this got worked out, closing it out!

  6. Nick Quaranto closed this discussion on 05 Nov, 2010 01:13 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

30 Oct, 2014 04:34 PM
30 Oct, 2014 02:46 PM
28 Oct, 2014 09:51 AM
23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM