can't update rubygems on non english windows version

Vasiliy's Avatar

Vasiliy

22 Sep, 2010 02:14 PM

Hello, I can't update (install gem) with non english user name on Windows Web Server 2008 Russian
I have tried :

gem update --system
gem install mechanize

ERROR: While executing gem ... (Errno::ENOENT)
         No such file or directory - C:\Users\Администратор

After some googling, have readed about non ascii sysbols issue, and have created new user - Adm,
and have tried again

gem update --system   - result - nothing to update
gem install mechanize - result - successfull installed

gem - v
1.3.7
ruby -v
1.8.6
  1. Support Staff 1 Posted by Nick Quaranto on 25 Sep, 2010 05:29 AM

    Nick Quaranto's Avatar

    Sounds like a bug with how RubyGems handles paths on Windows.

    http://github.com/rubygems/rubygems if you're willing to get a patch together, please feel free to submit one!

  2. Support Staff 2 Posted by John Barnette on 17 Nov, 2010 07:47 AM

    John Barnette's Avatar

    We have a ticket for this in the dev tracker. Closing.

  3. John Barnette closed this discussion on 17 Nov, 2010 07:47 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac