Problem to install rails

edgar7orres's Avatar

edgar7orres

13 Sep, 2010 10:19 PM

Hello,

I can´t to install rails in my red hat 5.2, I use the command # gem install rails but it show me

# gem install rails
ERROR:  http://gems.rubyforge.org/ does not appear to be a repository
ERROR:  could not find gem rails locally or in a repository

I checked with "gem env" and this shown:

# gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.4
  - RUBY VERSION: 1.8.7 (2009-06-12 patchlevel 174) [x86_64-linux]
  - INSTALLATION DIRECTORY: /usr/local//lib/ruby/gems/1.8
  - RUBY EXECUTABLE: /usr/local//bin/ruby
  - EXECUTABLE DIRECTORY: /usr/local//bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86_64-linux
  - GEM PATHS:
     - /usr/local//lib/ruby/gems/1.8
     - /root/.gem/ruby/1.8
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - http://gems.rubyforge.org/

I don´t know what to do, any idea?

Thank you!!

  1. Support Staff 1 Posted by Nick Quaranto on 19 Sep, 2010 02:33 PM

    Nick Quaranto's Avatar

    Sorry about the delay here!

    That seems strange, that version of RG should work fine. Could you paste the output from gem install rails -V ? Are you behind a proxy or firewall?

  2. 2 Posted by amy varga on 29 Oct, 2010 11:51 AM

    amy varga's Avatar

    Hi

    I am having a similar problem. This is the error I get when trying to install compass :

    C:\Windows\System32>gem install compass
    ERROR:  http://rubygems.org/ does not appear to be a repository
    ERROR:  Could not find a valid gem 'compass' (>= 0) in any repository
    

    This is my gem environment :

    C:\Windows\system32>gem environment
    RubyGems Environment:
      - RUBYGEMS VERSION: 1.3.7
      - RUBY VERSION: 1.8.6 (2010-02-04 patchlevel 398) [i386-mingw32]
      - INSTALLATION DIRECTORY: C:/Ruby186/lib/ruby/gems/1.8
      - RUBY EXECUTABLE: C:/Ruby186/bin/ruby.exe
      - EXECUTABLE DIRECTORY: C:/Ruby186/bin
      - RUBYGEMS PLATFORMS:
        - ruby
        - x86-mingw32
      - GEM PATHS:
         - C:/Ruby186/lib/ruby/gems/1.8
         - C:/Users/AVarga.D000786/.gem/ruby/1.8
      - GEM CONFIGURATION:
         - :update_sources => true
         - :verbose => true
         - :benchmark => false
         - :backtrace => false
         - :bulk_threshold => 1000
      - REMOTE SOURCES:
         - http://rubygems.org/C:\Users\AVarga.D000786>gem install rails -V
    

    I also did the gem install rails -V as suggested in yuor previous message :

    ERROR:  http://rubygems.org/ does not appear to be a repository
    Error fetching remote data:             Errno::ETIMEDOUT: A connection attempt f
    ailed because the connected party did not properly respond after a period of tim
    e, or established connection failed because connected host has failed to respond
    . - connect(2) (http://rubygems.org/yaml)
    Falling back to local-only install
    ERROR:  Could not find a valid gem 'rails' (>= 0) in any repository
    

    I am sitting behind a proxy and am using Windows 7

    Any help would be much appreciated as I believe I have tried everything

    Cheers
    Amy

  3. Support Staff 3 Posted by Nick Quaranto on 30 Oct, 2010 12:37 AM

    Nick Quaranto's Avatar
  4. Nick Quaranto closed this discussion on 30 Oct, 2010 12:37 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

30 Oct, 2014 04:34 PM
30 Oct, 2014 02:46 PM
28 Oct, 2014 09:51 AM
23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM