Unable to download data from https://rubygems.org/ - Received fatal alert: protocol_version

Kalina's Avatar

Kalina

21 Jun, 2018 08:03 AM

I saw that this issue is very often happened by another ruby developer. So the same problem but with gem 'bundler' (= 1.12.5) is by us.
Since 19. Juni 18 come again and again this error message:

ERROR: Could not find a valid gem 'bundler' (= 1.12.5), here is why:
          Unable to download data from https://rubygems.org/ - Received fatal alert: protocol_version (https://rubygems.org/specs.4.8.gz)

Can you please help us?
Best regards

  1. Support Staff 1 Posted by Aditya Prakash on 21 Jun, 2018 08:27 AM

    Aditya Prakash's Avatar

    Hi Kalina,

    Looks like your openssl client doesn't support TLSv1.2. Please consider updating it. We recently removed support for TLSv.1.0 and 1.1 https://blog.rubygems.org/2018/02/24/tls-10-and-11-deprecation-noti...

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac