Unable to download data from https://rubygems.org/ - timed out

bstefan93's Avatar

bstefan93

28 May, 2018 01:44 PM

gem install bundler
ERROR: Could not find a valid gem 'bundler' (>= 0), here is why:
          Unable to download data from https://rubygems.org/ - timed out (https://rubygems.org/latest_specs.4.8.gz)

can't seem to figure it out, been struggling with this for 2 days now, plz helperino

  1. Support Staff 1 Posted by kerrizor on 31 May, 2018 12:04 AM

    kerrizor's Avatar

    I'm sorry you've run into this!

    • Are you able to reach https://rubygems.org from this machine?
    • Can you tell us more about the environment this machine is in? Is it a laptop? A server in the cloud?
  2. 2 Posted by Kevin on 08 Jun, 2018 07:30 AM

    Kevin's Avatar

    I am having the same issue. I am trying to connect from a networked desktop machine running Windows 7 Pro.
    I am able to link to https://rubygems.org/ in my browser..

  3. 3 Posted by ecnelises on 08 Jun, 2018 11:49 AM

    ecnelises's Avatar

    Can you successfully wget https://rubygems.org/latest_specs.4.8.gz ?

  4. 4 Posted by Kevin on 08 Jun, 2018 12:23 PM

    Kevin's Avatar

    The item the gem install command is trying to access is https://rubygems.org/specs.4.8.gz which is different to your link.
     
    I can manually download this and the one from your link but not via the gem install command in the CLI.

  5. 5 Posted by ecnelises on 11 Jun, 2018 07:45 AM

    ecnelises's Avatar

    This is so strange, I'm not sure what I can do for help. Maybe you can install another Ruby version and test again. You can use `gem install bundler --verbose` for detailed error message.

  6. Support Staff 6 Posted by kerrizor on 15 Jul, 2018 07:29 PM

    kerrizor's Avatar

    Is this still an issue? I'm able to access this from my test machines around the net.

    (Which isn't to say you aren't experiencing this, but that it might have resolved itself?)

  7. 7 Posted by Kevin on 16 Jul, 2018 07:30 AM

    Kevin's Avatar

    It turned out to be a permissions issue. When api.rubygems.org was added it worked.

  8. Support Staff 8 Posted by kerrizor on 21 Jul, 2018 07:17 PM

    kerrizor's Avatar

    Great! Glad it sorted itself :)

  9. kerrizor closed this discussion on 21 Jul, 2018 07:17 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac