No permissions to manage my own gem

Jędrzej's Avatar

Jędrzej

29 Apr, 2018 09:40 AM

I've just created a new gem (for the first time), I ran gem build my_gem and tried to push to rubygems.org but I got a message 'You do not have permission to manage this gem'. What? Really? I don't have permissions to manage my newly created gem?
I ran gem owner my_gem and I got this:
- [email blocked]
Who the fuck is [email blocked]?????
gem owner my_gem my_email
You do not have permission to manage this gem
gem owner password_generator -r [email blocked]
You do not have permission to manage this gem

I am not going to lie but I am feel frustrated. I shouldn't even have to post this thread on the internet. It's so ridiculous. How's that even possible?

  1. kerrizor closed this discussion on 04 May, 2018 05:12 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac