Problems connecting to Rubygems

Bob Ruskin's Avatar

Bob Ruskin

18 Apr, 2018 12:58 PM

Hi Support,

We use ruby gems on a regular basis to assist us in building customer applications, however over the last few days we are experiencing problems building applications with error messages such as those. Reading through your documentation, we believe we may in fact be black listed. If this is the case, we do apologise for over utilising your services, and would like to talk to you about re-enabling access for ourselves so that we can once again re-use the APIs. Due to the number of issues we have seen, we have reduced the number of builds we are doing per day to reduce the number of calls to you but this doesn't appear to have resolved the issue. Can you please review the errors below and let us know what more we will need to do so that we may once again use the APIs.

Thanks.

---

---- Begin output of /opt/chef/embedded/bin/gem install "chef-handler-updated-resources" -q --no-rdoc --no-ri ----
STDOUT:
STDERR: ERROR: Could not find a valid gem 'chef-handler-updated-resources' (>= 0), here is why:
          Unable to download data from https://rubygems.org/ - Errno::ECONNRESET: Connection reset by peer - SSL_connect (https://api.rubygems.org/specs.4.8.gz)
ERROR: Possible alternatives: chef-handler-updated-resources

  1. 1 Posted by Jack A on 20 Apr, 2018 02:50 PM

    Jack A's Avatar

    I'm seeing a similar error as well:

    ERROR: Could not find a valid gem 'bundler' (>= 0), here is why:
              Unable to download data from https://rubygems.org/ - Errno::ECONNRESET: Connection reset by peer - SSL_connect (https://api.rubygems.org/latest_specs.4.8.gz)

    This appears to be happening on AWS (eu-west-1) but not from our corporate net connection

  2. 2 Posted by Alfredo on 25 Apr, 2018 04:26 PM

    Alfredo's Avatar

    Same problem here!

    ERROR: Could not find a valid gem 'bundler' (>= 0), here is why:
              Unable to download data from https://rubygems.org/ - Errno::ECONNRESET: Connection reset by peer - SSL_connect (https://api.rubygems.org/specs.4.8.gz)
    ERROR: Possible alternatives: bundler

    Did you get a solution?

  3. 3 Posted by Rafal on 26 Apr, 2018 09:52 AM

    Rafal's Avatar

    Same here. Some requests pass, but majority returns "Connection reset by peer"

  4. 4 Posted by Kevin Olbrich on 26 Apr, 2018 02:52 PM

    Kevin Olbrich's Avatar

    I have also seen this problem happen within one particular VPC in us-east-1, all of the outgoing traffic from that VPC goes through a NAT server. Sounds like we may have also gotten ourselves blacklisted somehow. Is there a resolution process or this?

  5. 5 Posted by Ferdy on 26 Apr, 2018 11:48 PM

    Ferdy's Avatar

    Had the same problem. api.rubygems.org change their certificate on Apr 25. I also had TLS problems for other sites but only on servers behind a NAT. I also updated the servers certificates list as well, but this did not fix the NAT issue.

    I upgraded and rebuilt a new NAT on amazon-nat-2017.09 and this has fixed the connectivity issues, we were previously at 2016.03

  6. 6 Posted by olbrich on 27 Apr, 2018 12:07 AM

    olbrich's Avatar

    Ferdy, were you able to inspect the SSL certificate for api.rubygems.org? I tried grabbing it directly with `openssl s_client -connect api.rubygems.org:443` and did not get a response (which is what led me to believe we were blacklisted).

  7. 7 Posted by Rongo on 27 Apr, 2018 11:54 AM

    Rongo's Avatar

    I can confirm this issue existing for instances behind NAT instance. I've switched currently to NAT Gateway service and it works again. The ip's are not blacklisted it's more a CDN problem rubygems.org rely on.

  8. 8 Posted by Olbrich, Kevin on 27 Apr, 2018 11:59 AM

    Olbrich, Kevin's Avatar

    Very strange. I have instances in a different vpc but same nat setup that are unaffected.

    Kevin Olbrich, Ph.D.
    Lead CDS Developer
    Clinical Decision Support
    McKesson Specialty Health
    [email blocked]
    919-618-3331
    ________________________________

  9. 9 Posted by Donald Webster on 30 Apr, 2018 04:21 AM

    Donald Webster's Avatar

    I'm having a similar issue from all of my Rackspace servers (timeout to RubyGems), but RubyGems is working fine locally and on Digital Ocean servers.

  10. 10 Posted by olbrich on 30 Apr, 2018 10:23 AM

    olbrich's Avatar

    I replaced my NAT server with a NAT gateway over the weekend (which was already planned, coincidentally), and service has been restored.

  11. 11 Posted by teeparham on 04 May, 2018 03:09 AM

    teeparham's Avatar

    I had the same issue on AWS - could not establish a SSL connection with api.rubygems.org from a server behind a NAT. Replacing the old NAT instance with amzn-ami-vpc-nat-hvm-2017.09.1.20180108-x86_64-ebs fixed it.

  12. Support Staff 12 Posted by kerrizor on 04 May, 2018 04:51 PM

    kerrizor's Avatar

    Hey all, thanks for writing in.. and apologies on the late reply, its been a hectic couple of weeks!

    • Is this still an active issue for anyone?
    • Has anyone had this issue and NOT been behind a NAT?
  13. 13 Posted by Bruno on 31 May, 2018 08:46 PM

    Bruno's Avatar

    Same issue here, on a fresh Ubuntu 18.04 install on my laptop

    ERROR: Could not find a valid gem 'bundler' (>= 0), here is why:
              Unable to download data from https://rubygems.org/ - Errno::ECONNRESET: Connection reset by peer - SSL_connect (https://api.rubygems.org/specs.4.8.gz)

    It happens with other sites like python pip.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac