Error while fetching gems

Tanuj's Avatar

Tanuj

08 Feb, 2018 01:20 PM

We have started seeing intermittent issues with fetching gems from yesterday. It has stopped working today completely.

Here is the error below while doing bundle install.

Gem::RemoteFetcher::FetchError Errno::ECONNRESET: Connection reset by peer - SSL_connect (https://rubygems.org/gems/erubi-1.7.0.gem)\nRetrying download gem from https://rubygems.org/ due to error (3/4): Gem::RemoteFetcher::FetchError Errno::ECONNRESET: Connection reset by peer - SSL_connect (https://rubygems.org/gems/erubi-1.7.0.gem)\nRetrying download gem from https://rubygems.org/ due to error (4/4): Gem::RemoteFetcher::FetchError Errno::ECONNRESET: Connection reset by peer - SSL_connect (https://rubygems.org/gems/erubi-1.7.0.gem)Installing erubi 1.7.0\nFetching mini_portile2 2.3.0\n\nRetrying download gem from https://rubygems.org/ due to error (2/4): Gem::RemoteFetcher::FetchError Errno::ECONNRESET: Connection reset by peer - SSL_connect (https://rubygems.org/gems/mini_portile2-2.3.0.gem)Installing mini_portile2 2.3.0\nFetching nokogiri 1.8.2\n\nRetrying download gem from https://rubygems.org/ due to error (2/4): Gem::RemoteFetcher::FetchError Errno::ECONNRESET: Connection reset by peer - SSL_connect (https://rubygems.org/gems/nokogiri-1.8.2.gem)Installing nokogiri 1.8.2 with native extensions\nFetching rails-dom-testing 2.0.3\nInstalling rails-dom-testing 2.0.3\nFetching crass 1.0.3\n\nRetrying download gem from https://rubygems.org/ due to error (2/4): Gem::RemoteFetcher::FetchError Errno::ECONNRESET: Connection reset by peer - SSL_connect (https://rubygems.org/gems/crass-1.0.3.gem)\nRetrying download gem from https://rubygems.org/ due to error (3/4): Gem::RemoteFetcher::FetchError Errno::ECONNRESET: Connection reset by peer - SSL_connect (https://rubygems.org/gems/crass-1.0.3.gem)\nRetrying download gem from https://rubygems.org/ due to error (4/4): Gem::RemoteFetcher::FetchError Errno::ECONNRESET: Connection reset by peer - SSL_connect (https://rubygems.org/gems/crass-1.0.3.gem)\nGem::RemoteFetcher::Fet...: Errno::ECONNRESET: Connection reset by peer -\nSSL_connect (https://rubygems.org/gems/crass-1.0.3.gem)\nAn error occurred while installing crass (1.0.3), and Bundler cannot continue.\nMake sure that gem install crass -v '1.0.3' succeeds before bundling.\n\nIn Gemfile:\n health_check was resolved to

  1. Support Staff 1 Posted by kerrizor on 10 Feb, 2018 10:50 PM

    kerrizor's Avatar

    At this time Fastly believes the issue resolved. More information can be found here: https://status.fastly.com/incidents/k3zzxnkz4vcd

  2. kerrizor closed this discussion on 10 Feb, 2018 10:50 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac