Cannot sign in, no error message

andrea.campi's Avatar

andrea.campi

17 Aug, 2010 01:10 AM

Hi,

it seems I cannot login, even though my password is correct.

Earlier I could not remember my password, so I clicked on "Forgot", clicked on the email I received and created a new one.
Now if I try to sign in I get redirected back to the home page with no error.
If I mistype my account info on purpose, I do get an error.
The company account is working, so there's probably something wrong with my account.
Any idea?

Thanks in advance,
Andrea

  1. 1 Posted by juanjo on 19 Aug, 2010 10:21 PM

    juanjo's Avatar

    I'm having exactly the same problem with my account.

  2. Support Staff 2 Posted by Nick Quaranto on 31 Aug, 2010 03:31 AM

    Nick Quaranto's Avatar

    I'm not seeing anything unusual about your accounts. What OS/Browser are you trying on? And does signing in through the rubygems client work? (As in, try gem owner rails, you'll get denied but at least you'll sign in)

  3. 3 Posted by Olivier Brisse on 06 Sep, 2010 05:39 AM

    Olivier Brisse's Avatar

    I have the same problem.
    I can access my dashboard on my home computer but not at work.
    I'm using ubuntu with chrome and firefox.

    However I can sign in trough the rubygems client.

  4. Support Staff 4 Posted by Nick Quaranto on 07 Sep, 2010 10:33 PM

    Nick Quaranto's Avatar

    Can you try clearing your cookies? Grasping at straws here.

  5. 5 Posted by Olivier Brisse on 07 Sep, 2010 11:37 PM

    Olivier Brisse's Avatar

    Still the same problem.

    I've tried cleaning the cache and cookies, and also tried in
    Chrome "incognito mode".

    It's weird because as stated by Andrea I'm redirected to the front page with no error message but if I mistype my password on purpose I have an error message.

    Olivier

  6. 6 Posted by Juanjo on 10 Sep, 2010 07:10 PM

    Juanjo's Avatar

    Still having the problem.
    The rubygems client works ok. But I can't log in via web (using OSX 10.6) with any browser (tried FF, Safari, Chrome and Plainview), deleting caches & cookies.

  7. Support Staff 7 Posted by Nick Quaranto on 21 Oct, 2010 10:01 PM

    Nick Quaranto's Avatar

    This totally fell off my radar, sorry. Still not 100% sure about what to do here. The accounts look fine, I haven't seen any recent reports besides these of users not being able to log in. Is this still happening? Can you provide clear steps to reproduce it? Thanks.

  8. 8 Posted by Ben Klang on 22 Oct, 2010 01:15 AM

    Ben Klang's Avatar

    I have this problem as well.

    I think the issue in my case has to do with my account not getting originally activated. I activated the account on help.rubygems.org but never received an activation email for rubygems.org proper. In any event I can log in and I trigger a password reset, but even after both of those actions I never get the top menu that I should see.

  9. Support Staff 9 Posted by Nick Quaranto on 05 Nov, 2010 01:00 AM

    Nick Quaranto's Avatar

    Everyone on this thread, please try signing in again, I think we're close to solving this login bug. Thanks!

  10. 10 Posted by Olivier Brisse on 07 Nov, 2010 10:46 PM

    Olivier Brisse's Avatar

    It works now !

    However, my list of subscribed gems is now empty. Is it normal ?

  11. 11 Posted by Muriel Salvan on 09 Nov, 2010 11:06 AM

    Muriel Salvan's Avatar

    Hi

    The problem still remains for me.

    My user was imported from RubyForge, and this is the first time I try to sign up on RubyGems. I also asked to reset my password 1 hour ago, but no mail was sent so far.

    I can use the client (using gem push) successfully with the email I registered from RubyForge and the corresponding password.

    Muriel

  12. 12 Posted by Muriel Salvan on 09 Nov, 2010 02:04 PM

    Muriel Salvan's Avatar

    [update]

    I have received the mail to change my password, changed it, but I am still redirected to the home page without any error message when I log in.

    I also tried using the previous password, I got an error message "Bad email or password".

    I tried with cookies and cache cleaned, both in Chrome and Firefox: same results.

    Muriel

  13. 13 Posted by Frank on 12 Nov, 2010 07:04 PM

    Frank's Avatar

    Same problem here... I cannot login on the website. rubygems client works fine though

  14. Support Staff 14 Posted by Nick Quaranto on 16 Nov, 2010 01:33 AM

    Nick Quaranto's Avatar

    Seems like I forgot to hit a few (38,000!) accounts from the import with restting their token. Muriel and Frank, can you try logging in again?

  15. 15 Posted by Frank on 16 Nov, 2010 01:38 AM

    Frank's Avatar

    Works like a charm! Thanks Nick

  16. Nick Quaranto closed this discussion on 16 Nov, 2010 03:27 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM
18 Oct, 2014 08:39 PM
16 Oct, 2014 12:41 PM
06 Oct, 2014 02:30 PM