Does not appear to be in repository

Laxman Kumar's Avatar

Laxman Kumar

13 Aug, 2010 10:00 PM

while installing gems i am getting

ERROR: http://rubygems.org/ does not appear to be a repository
ERROR: Could not find a valid gem 'rails' (>= 0) in any repository

See the details below

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\>cd ruby

C:\ruby>gem update --system --no-rdoc --no-ri
Updating RubyGems
ERROR:  http://rubygems.org/ does not appear to be a repository
ERROR:  While executing gem ... (Gem::RemoteFetcher::FetchError)
    Errno::ETIMEDOUT: A connection attempt failed because the connected party di
d not properly respond after a period of time, or established connection failed
because connected host has failed to respond. - connect(2) (http://rubygems.org/
yaml)

C:\ruby>gem -v
1.3.7

C:\ruby>gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.7
  - RUBY VERSION: 1.9.1 (2010-07-02 patchlevel 429) [i386-mingw32]
  - INSTALLATION DIRECTORY: C:/Ruby191/lib/ruby/gems/1.9.1
  - RUBY EXECUTABLE: C:/Ruby191/bin/ruby.exe
  - EXECUTABLE DIRECTORY: C:/Ruby191/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86-mingw32
  - GEM PATHS:
     - C:/Ruby191/lib/ruby/gems/1.9.1
     - N:/.gem/ruby/1.9.1
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - http://rubygems.org/

C:\ruby>
  1. Support Staff 2 Posted by Nick Quaranto on 14 Aug, 2010 04:19 PM

    Nick Quaranto's Avatar

    Are you behind a proxy or firewall?

    There's information about setting a HTTP proxy up here: http://docs.rubygems.org/read/chapter/13#page51

  2. Nick Quaranto closed this discussion on 14 Aug, 2010 04:19 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac