Can not install logstash-core

Jian-Hong Liao's Avatar

Jian-Hong Liao

14 Oct, 2017 03:00 PM

gem install logstash-core -V
HEAD https://api.rubygems.org/api/v1/dependencies
200 OK
GET https://api.rubygems.org/api/v1/dependencies?gems=logstash-core
200 OK
ERROR:  Could not find a valid gem 'logstash-core' (>= 0) in any repository
GET https://api.rubygems.org/latest_specs.4.8.gz
304 Not Modified
ERROR:  Possible alternatives: logstasher, logstash-lite, logstash-file, logstash-cli, logstash_sqs

Rubygems Ver 2.6.13

  1. Support Staff 1 Posted by Eric Hodel on 14 Oct, 2017 08:41 PM

    Eric Hodel's Avatar

    Are you installing from jruby?

    The gem only supports the java platform: https://rubygems.org/gems/logstash-core

  2. 2 Posted by Jian-Hong Liao on 15 Oct, 2017 09:18 AM

    Jian-Hong Liao's Avatar

    Hi, Eric

    Thanks for your kind help.
    I solved it!

  3. David Radcliffe closed this discussion on 17 Oct, 2017 12:15 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac