Need a series of gems removed.

durran's Avatar

durran

08 Aug, 2010 07:18 PM

The is a request for the mongoid gem.

Due to the sorting of gem names, once we hit a beta9 version of the gem any later beta release would not fall after the beta9 and subsequently installing with --pre would never download any new gems. Due to this we renamed the gems beta.n so new releases would get sorted properly, and went back and re-released all the previous valid versions of the gem under this scheme.

I've yanked the badly named versions and installing with --pre works like a charm now, but to avoid confusion I would like all the yanked gems deleted. Those libraries with dependencies on any of those versions have been notified of the change.

The versions I would like deleted:

2.0.0.beta9 June 30, 2010 yanked
2.0.0.beta8 June 30, 2010 yanked
2.0.0.beta7 June 16, 2010 yanked
2.0.0.beta6 May 17, 2010 yanked
2.0.0.beta5 May 17, 2010 yanked
2.0.0.beta4 April 20, 2010 yanked
2.0.0.beta3 April 12, 2010 yanked
2.0.0.beta2 April 4, 2010 yanked
2.0.0.beta11 July 25, 2010 yanked
2.0.0.beta10 July 23, 2010 yanked
2.0.0.beta1 March 25, 2010 yanked

Thank you very much for your help.

  • D
  1. Support Staff 1 Posted by Nick Quaranto on 14 Aug, 2010 04:08 PM

    Nick Quaranto's Avatar

    We tend not to delete gems unless if there's some malicious or harmful code in there...I don't think we've seen this bug before simply because someone hasn't pushed that many prereleases yet. Clearly it's more of a RG bug with alpha sorting.

    Probably what we could start doing is hiding the yanked gems from the gem view, and only show it on the versions index (http://rubygems.org/gems/mongoid/versions).

  2. Nick Quaranto closed this discussion on 14 Aug, 2010 04:08 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac