Failed to install 'rubynode' gem after upgrade to Mac OS X 10.6

Richard's Avatar

Richard

07 Aug, 2010 12:00 AM

Hi,

I've just upgraded to Mac OS X 10.6, and was following the instructions on the Rails blog (http://weblog.rubyonrails.org/2009/8/30/upgrading-to-snow-leopard) to upgrade my gems etc. This worked OK, with the exception of the 'rubynode' gem which failed to install. This is on a normal Mac OS X install of Ruby, I don't have MacPorts or anything like that installed. The errors were are follows:

ERROR:  Error installing rubynode:
ERROR: Failed to build gem native extension.

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby extconf.rb
==================== ERROR =====================
Please set RUBY_SOURCE_DIR to the source path of ruby 1.8.7 (2009-06-12)!
================================================

Can anyone tell me how to fix this (or even if I'm likely to need the 'rubynode' gem for Rails development)?
I appreciate that this may not be right place to ask this question, so please point me in the right direction if so.

Thanks,
Richard

  1. Support Staff 2 Posted by Nick Quaranto on 14 Aug, 2010 04:01 PM

    Nick Quaranto's Avatar

    Seems like some others have had more luck trying to figure this out:

    http://groups.google.com/group/comp.lang.ruby/browse_thread/thread/...

  2. Nick Quaranto closed this discussion on 14 Aug, 2010 04:01 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac