Trying to install a local .gem leads to an error and the folder being wiped

Maaike's Avatar

Maaike

09 Apr, 2017 04:13 PM

Hi there! I'm attempting to install a gem from a local directory (this because I altered a file within to work around an issue). However, when I run gem install <gemname.gem> --local ./<gemname.gem> from within the folder containing the .gem file I get the following error:

Temporarily enhancing PATH to include DevKit...
ERROR:  While executing gem ... (Errno::ENOENT)
    No such file or directory @ rb_sysopen - C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/<gemname>/<gemname.gem>

Then, when I want to go back to the folder, it's completely empty except for a folder named ext, which is empty itself. I'm fairly new to Ruby, so I'm really not sure what is happening, or what I can do to solve it. I tried the solution suggested in this (http://help.rubygems.org/discussions/problems/545-cannot-install-ru...) thread (making sure the %USERPROFILE% path is set correctly), but as far as I could see this did not apply to me.

Any help would be greatly appreciated, and please let me know if more information is needed!

  1. Support Staff 1 Posted by Aditya Prakash on 12 Apr, 2017 07:20 PM

    Aditya Prakash's Avatar

    Hi Maaike,

    gem install gemname.gem --local ./gemname.gem

    You don't need to specify gem file twice. Please check: http://help.rubygems.org/kb/rubygems/installing-gems-with-no-network and
    http://stackoverflow.com/questions/220176/how-can-i-install-a-local...

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac