Repository path issues while updating gem

Pilou's Avatar

Pilou

30 Jul, 2010 09:51 AM

Hi,

I'm having some issues while trying to update gems on windows XP. I've installed InstantRails 2.0 and here are my ruby versions :

ruby : 1.9.1 p429
gem : 1.3.7
rails : seems to not be installed, trying "gem install rails --include-dependencies" and i have the same error message when I run "gem update --system"

Here is the error message :
" ERROR: http://rubygems.org/ does not appear to be a repository
ERROR: Could not find a valid gem 'rails' ()= 0) in any repository
"

I don't have internet connections issues, ping rubygems.org works fine...
I have full admin rights on my windows xp session.

Anyone can help ?
Thx.

  1. 2 Posted by Pilou on 30 Jul, 2010 02:10 PM

    Pilou's Avatar

    Hi again guys.

    I tried to install InstantRails v1.7 instead of 2.0 and Rails seems to be installed...

    However, I'm stuck with a new issue when I run any commands, even "ruby script/server"

    "ERROR: While executing gem ... (gem::RemoteFetcher::FetchError) Too many open files - socket(2)(Errno::EMFILE)"

    I've try looking arround for a solution and i tried to edit the "c:\windows\system32\config.nt" file to add some files descriptors but did nothing...

    Any ideas ?

  2. Support Staff 3 Posted by Nick Quaranto on 01 Aug, 2010 03:54 PM

    Nick Quaranto's Avatar

    Yeah, this seems really strange. Can you paste the output of gem env and gem install rails -V ?

  3. Support Staff 4 Posted by John Barnette on 17 Nov, 2010 07:46 AM

    John Barnette's Avatar

    Haven't heard back on this. Closing. Pilou, please attach the info Nick requested if you'd like the discussion reopened.

  4. John Barnette closed this discussion on 17 Nov, 2010 07:46 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac