push fails with "You do not have permission to push to this gem." Possible ownership issue?

james's Avatar

james

25 Jul, 2010 10:46 PM

I tried to push a new gem of 'rawr'. I got the error, "You do not have permission to push to this gem."

I searched the site and apparently there already exists older rawr gems up on rubygems.org.

Over on rubyforge I was a rawr project admin. I tried to sign in to rubygems.org using my rubyforge account name, but it failed. I tried to have rubygems.org send me my password, but it said there was no account for the given E-mail address ([email blocked]), the one I used over on rubyforge.org.

So there's a gem on rubygems.org that I'm suppose to be the admin for, but I have no access to it.

How can we fix this?

James Britt

  1. Support Staff 1 Posted by Nick Quaranto on 31 Jul, 2010 05:47 PM

    Nick Quaranto's Avatar

    I've added the two users with ownership on this gem, [email blocked] and [email blocked], to this thread. Usually the original pushers just do it out of good will, and the ownership gets transferred back just fine. You can use gem owner to add James back onto this gem.

  2. 2 Posted by james on 31 Jul, 2010 07:52 PM

    james's Avatar

    "I've added the two users with ownership on this gem, [email blocked] and [email blocked], to this thread."

    Please look at rubyforge.org . There are three owners. I am one of them. Actually, I'm about the only active one, so leaving me off is simply wrong.

    How does rubygems.org even determine who owns a gem? What's the authoritative source? The rubyforge project has been where admin tasks have been handled. Why is it not used to determine ownership of gems here?

  3. Support Staff 3 Posted by Nick Quaranto on 01 Aug, 2010 04:03 PM

    Nick Quaranto's Avatar

    Ah, sorry, I didn't see the rubyforge project. Usually we just take a look over there, sorry that I missed it. I've added you as an owner, you should be all set.

  4. Nick Quaranto closed this discussion on 01 Aug, 2010 04:03 PM.

  5. james re-opened this discussion on 01 Aug, 2010 10:30 PM

  6. 4 Posted by james on 01 Aug, 2010 10:30 PM

    james's Avatar

    I cannot sign in using my rubyforge account E-mail address.

    When I tried signining in I did not get any error message, but even
    though I'm redirected to the main page it does not show my user name,
    and has a link to sign in (where it should have a link to sign out).

    rubygems.org now seems to know about my rubyforge.org account E-mail
    address (unlike a few days ago), and sent me a "reset password" link
    when I requested it.

    I used that to set a new password, but it didn't help. When I again try
    to sign in, I just end up on the home page but I'm not signed in.

    I tried this using Firefox, Opera, and Chrome, so I don't think this is
    a browser issue.

  7. Support Staff 5 Posted by Nick Quaranto on 02 Aug, 2010 12:52 AM

    Nick Quaranto's Avatar

    The account's email is "[email blocked]" and the handle is "jamesgbritt". That definitely doesn't sound normal...maybe try clearing your cookies?

  8. 6 Posted by james on 02 Aug, 2010 01:43 AM

    james's Avatar

    Clearing cookies makes no difference, and I've never signed into the
    site using Opera before, and it didn't work there (nor in chrome, nor
    firefox). I tried on another machine, same thing. No sign-in.

    However, I was able to push a gem using that account. I just can't sign
    in with it.

  9. Support Staff 7 Posted by Nick Quaranto on 14 Aug, 2010 03:33 PM

    Nick Quaranto's Avatar

    Is this still happening? I haven't heard any other problems with logging in, at least lately.

  10. 8 Posted by Pjammer on 20 Oct, 2010 02:05 AM

    Pjammer's Avatar

    It happened to me, where you log in with a 'suspected' email address (one i use everywhere) and it let me in. But it didn't look like it did.... Then when i logged in with my 'real' email and pwd, it showed the dashboard etc. Before it didn't, and just said Sign In Sign Up etc, in the right hand upper nav cluster.

  11. Support Staff 9 Posted by Nick Quaranto on 04 Nov, 2010 05:19 PM

    Nick Quaranto's Avatar

    I think we're starting to find the issue, James, can you try signing in again?

    pjammer, what's your account email or handle?

  12. Nick Quaranto closed this discussion on 18 Mar, 2011 08:19 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac