Trying to instal the download for Ruby Gems

Stan Willard's Avatar

Stan Willard

02 Jul, 2014 08:08 PM

I cannot rune the file setup.rb. It give "permission denied" when I try to run it

  1. 2 Posted by Stan Willard on 02 Jul, 2014 08:12 PM

    Stan Willard's Avatar

    the knowledge base did not seem relavent

  2. Support Staff 3 Posted by Eric Hodel on 02 Jul, 2014 08:44 PM

    Eric Hodel's Avatar

    All modern versions of Ruby have RubyGems included so there should be no need to run ruby setup.rb. What version of Ruby did you install?

    How did you run setup.rb?

  3. 4 Posted by Stan Willard on 03 Jul, 2014 03:48 AM

    Stan Willard's Avatar

    I believe it is 1.8.7.72 (9/22/13) version of Ruby

    I ran it by using the command ./setup.rb in the director where this file (setup) was found

  4. Support Staff 5 Posted by Eric Hodel on 03 Jul, 2014 10:35 PM

    Eric Hodel's Avatar

    You need to run ruby setup.rb. The file is not executable. See the "Manual Install" directions at the bottom of UPGRADING.rdoc in your unpacked tarball.

    Also note that ruby 1.8.7 is long out of date and no longer receives security fixes.

  5. 6 Posted by STANLEY WILLARD on 04 Jul, 2014 12:18 AM

    STANLEY WILLARD's Avatar

    Thank you for your patience, I am working on the "Manuel Install"

    Stan

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac