Can't resolve rubygems.org from CLI

Chris's Avatar

Chris

16 Apr, 2014 09:36 AM

Hi,

Up until now I haven't had an issue installing gems but now I can't even install anything but weirdly I can run gem update without any issues, I've completed all the checks on my end including...

  • Simply opening rubygems.org in Chrome and Safari ( Result: success )
  • Attempted to ping the TLD using ping rubygems.org ( Result: fail )
  • Attempted to ping the IP using iP using ping 54.245.255.174 ( Result: fail )

Ping results

PING rubygems.org (54.245.255.174): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3

I've triple checked my network and there is nothing wrong with it, I've tried a whole bunch of things such as verifying that RVM has the most up-to-date certs which it does, I've tried removing the secure gems source and only leaving the non-secure source, that didn't work and I've gone as far as re-installing ruby all-together.

I don't know what else to try, I'm a bit dumfounded by this, any guidance would be greatly appreciated.

For reference, here is one of the commands I'm trying

gem install animation --pre
ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError)
bad response Service Unavailable 503 (https://api.rubygems.org/api/v1/dependencies?gems=compass)

EDIT

Forgot about my versions and what not

  • ruby 2.1.1p76 (2014-02-24 revision 45161) [x86_64-darwin13.0]
  • gem v2.2.2
  • rvm 1.25.22 (stable)
  1. 1 Posted by Nicolas on 16 Apr, 2014 11:50 AM

    Nicolas's Avatar

    Hi,

    Same issue for me.

    gem install gandi deep_merge r10k
    ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError)
    bad response Service Unavailable 503 (https://api.rubygems.org/api/v1/dependencies?gems=multi_json)

  2. 2 Posted by Chris on 17 Apr, 2014 02:59 PM

    Chris's Avatar

    So out of no where everything is working normally again so I can only assume it was a DNS issue at Amazon.

  3. Support Staff 3 Posted by Nick Quaranto on 25 Apr, 2014 01:21 AM

    Nick Quaranto's Avatar

    Bummer. :( Sorry about that hiccup!

  4. Nick Quaranto closed this discussion on 25 Apr, 2014 01:21 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

30 Oct, 2014 04:34 PM
30 Oct, 2014 02:46 PM
28 Oct, 2014 09:51 AM
23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM