Ruby on Rails Gem Install Error

David Bailey's Avatar

David Bailey

17 Mar, 2014 04:06 PM

When I try to install Ruby on Rails, I get the following error messages.

C:\Users\029607\Documents\NDAC Tech Studies\TES3>gem install bundler --source "h
ttp://rubygems.org"

Successfully installed bundler-1.5.3
WARNING: Unable to pull data from 'https://rubygems.org/': SSL_connect SYSCALL returned=5 errno=0 state=SSLv2/v3 read server hello A (https://api.rubygems.org/latest_specs.4.8.gz)
1 gem installed

C:\Users\029607\Documents\NDAC Tech Studies\TES3>bundle install

Fetching source index from https://rubygems.org/
Retrying source fetch due to error (2/3): Bundler::HTTPError Could not fetch specs from https://rubygems.org/
Retrying source fetch due to error (3/3): Bundler::HTTPError Could not fetch specs from https://rubygems.org/
Could not fetch specs from https://rubygems.org/

Why is this happening?

Sincerely,
David

  1. Support Staff 1 Posted by Nick Quaranto on 25 Apr, 2014 12:48 AM

    Nick Quaranto's Avatar

    Sounds like you have a proxy. Please check out gem help env to see how to configure that.

  2. Nick Quaranto closed this discussion on 25 Apr, 2014 12:48 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

30 Oct, 2014 04:34 PM
30 Oct, 2014 02:46 PM
28 Oct, 2014 09:51 AM
23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM