cant gem install rails?

nitefalll's Avatar

nitefalll

28 Jan, 2014 11:17 PM

ERROR: Could not find a valid gem 'rails' (>= 0), here is why:
Unable to download data from https://rubygems.org/ - SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (https://bb-m.rubygems.org/quick/Marshal.4.8/rails-4.0.2.gemspec.rz)

tried to load rails:
'\curl -sSL https://get.rvm.io | bash -s stable --rails'

but that results in the error above. I've updated everything

$ rvm -v

rvm 1.25.15 (stable) by Wayne E. Seguin [email blocked], Michal Papis [email blocked] [https://rvm.io/]

$ rvm osx-ssl-certs status all Certificates for /etc/pki/tls/cert.pem: Up to date.
$ rvm osx-ssl-certs update all Updating certificates for /etc/pki/tls/cert.pem: Already are up to date.
$ gem update --system Latest version currently installed. Aborting.

but no bueno and I'd rather not re-install the centOS on this box.

  1. Support Staff 1 Posted by Nick Quaranto on 16 Apr, 2014 07:26 PM

    Nick Quaranto's Avatar

    Is this still happening?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac