Ill-formed requirement issue

pub's Avatar

pub

25 Jan, 2014 05:16 PM

Whenever I try to install jekyll (sudo gem install -v jekyll), gem install fails with a BadRequirementError. I have no clue what's going on, because that used to work. Is my installation of Ruby or RubyGems corrupt? Anyone seen this problem?

  1. 2 Posted by neo on 25 Jan, 2014 05:26 PM

    neo's Avatar

    try sudo gem install jekyll to install the latest version of the gem
    or sudo gem install jekyll -v 'version no' to install a particular version of the gem.

  2. Support Staff 3 Posted by Nick Quaranto on 16 Apr, 2014 06:59 PM

    Nick Quaranto's Avatar

    Is this still happening? You might have better luck on StackOverflow with this kind of issue, this site tends to be for help with rubygems.org specifically, not for installation of gems.

  3. Nick Quaranto closed this discussion on 16 Apr, 2014 06:59 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac