Load Error...

Jitendra's Avatar

Jitendra

31 Dec, 2013 06:08 PM

Hi Guys,

i was trying to install rails and i got error like atomic native gem then i run DevKit and when i gave command "ruby dk.rb init"
then is shows 'in require' : cannot load such file -- rubygems.rb.

kindly suggest me what should i do.
i am using windows 7 and ruby 1.9.3.

  1. Support Staff 1 Posted by Luis Lavena on 31 Dec, 2013 06:18 PM

    Luis Lavena's Avatar

    Please direct your questions to rubyinstaller mailing list.

    Please include all version information about the ruby you downloaded, the
    devkit filename you downloaded and the exact directories you installed and
    extracted both.

    Sorry for top posting. Sent from mobile.

  2. 2 Posted by Jitendra on 31 Dec, 2013 06:23 PM

    Jitendra's Avatar

    i have downloaded ruby 1.9.3 for Windows and and DevKit-tdm-32-4.5.2-20111229-1559-sfx.exe.
    i installed both in E directory and i extracted DevKit in E:\Ruby193\devkit.

  3. Support Staff 3 Posted by Luis Lavena on 31 Dec, 2013 06:46 PM

    Luis Lavena's Avatar

    Hello,

    As I mentioned before: please provide the *exact* version information of
    Ruby, what is the output of "ruby -v" in the command prompt?

    That is the version information I was asking.

    You mention E:\Ruby193, that is the exact directory you installed?

    Can you provide the exact output of the following commands:

    SET PATH

    where ruby.exe

    where gem.bat

    ruby -v

    gem env

    ---

    Last but not least, invokes to dk.rb needs to happen *inside* DevKit
    directory, please confirm above commands output.

    PS: I mention bring this to RubyInstaller mailing list since this is a
    support site of rubygems.org, not specific problems about Ruby on Windows.
    In the future, please direct your questions to the right places to get
    responses.

  4. 4 Posted by Jitendra on 31 Dec, 2013 06:59 PM

    Jitendra's Avatar

    Hi,

    output of output of "ruby -v" is below

    E:\Ruby193>ruby -v ruby 1.9.3p484 [i386-mingw32]

    where ruby.exe : E:\Ruby193\bin

    where gem.bat : E:\Ruby193\bin

    ruby -v : E:\Ruby193>ruby -v
    ruby 1.9.3p484 [i386-mingw32]

    gem env : internal:gem_prelude:1:in 'require':cannot load such file -- rubygems.rb
    from internal:gem_prelude:1:in ''

  5. Support Staff 5 Posted by Luis Lavena on 31 Dec, 2013 07:02 PM

    Luis Lavena's Avatar

    Receiving the following:

    > gem env : internal:gem_prelude:1:in 'require':cannot load such file --
    rubygems.rb
    > from internal:gem_prelude:1:in ''

    Might indicate a broken installation that is missing files.

    Please check again how you installed or extracted Ruby 1.9.3-p484, since
    the RubyGems files *are part of the installer*.

  6. 6 Posted by Jitendra on 31 Dec, 2013 07:04 PM

    Jitendra's Avatar

    sure

  7. 7 Posted by Jitendra on 31 Dec, 2013 07:41 PM

    Jitendra's Avatar

    Hi,

    I installed ruby 1.9.3 p484 but still same problem is coming.

  8. Support Staff 8 Posted by Luis Lavena on 31 Dec, 2013 07:47 PM

    Luis Lavena's Avatar

    Did you download rubyinstaller-1.9.3-p484.exe ?

    That installer contains all the required files for Ruby and RubyGems to
    work properly.

    I'm thinking that something in your computer might be interfering with the
    extraction or installation of the files.

  9. 9 Posted by Jitendra on 31 Dec, 2013 07:52 PM

    Jitendra's Avatar

    Hi,

    i have installed Java and tomcat and visual studio 2008.
    does this create the problem for Ruby?

  10. Support Staff 10 Posted by Luis Lavena on 31 Dec, 2013 07:56 PM

    Luis Lavena's Avatar

    No, but is clear that for some reason files are not getting extracted
    properly.

    Please confirm you have used the installer and you have downloaded it from
    rubyinstaller.org.

    I'm not sure what else can I suggest for you to do, except attempt to
    remove and to extract a different version of Ruby and see if the problem
    persist with that version too.

  11. 11 Posted by Jitendra on 31 Dec, 2013 08:00 PM

    Jitendra's Avatar

    Yes the same version i download and installed and downloaded from rubyinstaller.org.
    i will try for Ruby 2.0.0- p353.

  12. 12 Posted by Jitendra on 31 Dec, 2013 08:24 PM

    Jitendra's Avatar

    Hi,

    I tried with Ruby 2.0.0-p353 but still same error is coming.

  13. Support Staff 13 Posted by Luis Lavena on 31 Dec, 2013 08:55 PM

    Luis Lavena's Avatar

    Definitely, there is something in your environment that is affecting Ruby
    normal behavior.

    Please install TeamViewer, I'll be in one hour on IRC at #rubyinstaller
    channel so I can assist you on fixing this.

  14. 14 Posted by Jitendra on 31 Dec, 2013 10:45 PM

    Jitendra's Avatar

    yes sure i am downloading it and will inform you once i will done it

  15. 15 Posted by Jitendra on 31 Dec, 2013 10:51 PM

    Jitendra's Avatar

    Hi ,

    I am done with team viewer.
    now what is next step.

  16. Support Staff 16 Posted by Luis Lavena on 31 Dec, 2013 10:53 PM

    Luis Lavena's Avatar

    Please join rubyinstaller channel on irc.

    Sorry for top posting. Sent from mobile.

  17. 17 Posted by Jitendra on 31 Dec, 2013 10:55 PM

    Jitendra's Avatar

    how to join?
    kindly assist me to get connect with irc.

  18. Support Staff 18 Posted by Luis Lavena on 31 Dec, 2013 10:58 PM

    Luis Lavena's Avatar

    You can use a web client to connect to freenode:

    http://webchat.freenode.net/

  19. 19 Posted by Jitendra on 31 Dec, 2013 11:00 PM

    Jitendra's Avatar

    it is asking for username and password.
    what i have to fill?

  20. Support Staff 20 Posted by Luis Lavena on 31 Dec, 2013 11:02 PM

    Luis Lavena's Avatar

    Hello,

    Is not asking you for username or password, is asking you for nickname and
    channel

    Nickname: your name
    Channel: #rubyinstaller

    (as mentioned before)

  21. 21 Posted by Jitendra on 31 Dec, 2013 11:04 PM

    Jitendra's Avatar

    i am logged in and i got your name there.

    now what is next step.

  22. 22 Posted by Jitendra on 31 Dec, 2013 11:06 PM

    Jitendra's Avatar

    my id is 685 137 256

    password is 3240

  23. 23 Posted by Jitendra on 31 Dec, 2013 11:09 PM

    Jitendra's Avatar

    i am not getting way that how i could reply you.

  24. Support Staff 24 Posted by Luis Lavena on 31 Dec, 2013 11:11 PM

    Luis Lavena's Avatar

    Jitendra:

    There is a text field at the bottom of the Freenode webchat window, you
    type in there, and hit enter to reply...

  25. Support Staff 25 Posted by Luis Lavena on 31 Dec, 2013 11:26 PM

    Luis Lavena's Avatar

    Hello,

    As indicated over IRC and thanks to the TeamViewer session, the issue has been sorted out.

    The user had installed Ruby and extracted the DevKit on top of it instead on a dedicated folder.

    That action affected the behavior of Ruby, RubyGems and of course, the DevKit.

  26. Luis Lavena closed this discussion on 31 Dec, 2013 11:26 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM
18 Oct, 2014 08:39 PM
16 Oct, 2014 12:41 PM
06 Oct, 2014 02:30 PM