HTTP/1.1 413 Request Entity Too Large returned from /api/v1/dependencies

Chris Hart's Avatar

Chris Hart

13 Feb, 2013 04:24 PM

Hello,

When using bundler 1.2.3 I noticed that we were receiving an HTTP error retrieving dependencies when running bundle install. When I ran the command with verbose, the URL that was causing the error is:

http://bundler.rubygems.org/api/v1/dependencies?gems=tzinfo,arel,ac...

Trying this same request from a command line using curl I see an HTTP 413 error coming back from the rubygems server:

  • About to connect() to bundler.rubygems.org port 80 (#0)
  • Trying 107.20.228.215...
  • connected
  • Connected to bundler.rubygems.org (107.20.228.215) port 80 (#0) > GET /api/v1/dependencies?gems=tzinfo,arel,activemodel,pg-hstore,rake,activerecord-jdbcpostgresql-adapter,multi_json,i18n,builder,memcache-client,json,girl_friday,xml-simple,mime-types,uuidtools,httparty,sass,xpath,rack-test,rack,selenium-webdriver,culerity,celerity,hoe,coffee-script,railties,actionpack,sprockets,compass,bcrypt-ruby,orm_adapter,warden,factory_girl,rcov,rack-oauth2,httpclient,rest-client,restclient_with_cert,win32console,thor,posix-spawn,term-ansicolor,hashie,faraday_middleware,faraday,terminal-table,lumberjack,pry,listen,sys-uname,rb-inotify,libnotify,bundler,open_gem,ffi,childprocess,sys-proctable,sfl,ambry,metaclass,echoe,racc,tenderlove-frex,rake-compiler,rexical,weakling,ruby-hmac,newgem,jwt,multi_xml,httpauth,faraday-middleware,cocaine,right_aws,thoughtbot-shoulda,actionmailer,activeresource,actionwebservice,rspec-mocks,rspec-expectations,rspec-core,cucumber,diff-lcs,syntax,spicycode-rcov,webrat,tilt,shoulda-context,bourne,simplecov-html,win32-process,libv8,ref,eventmachine,daemons,eventmachine-le,http_parser.rb,preforker,simple_oauth,execjs,raindrops,kgio,crack,addressable,POpen4 HTTP/1.1 > User-Agent: curl/7.24.0 (x86_64-apple-darwin12.0) libcurl/7.24.0 OpenSSL/0.9.8r zlib/1.2.5 > Host: bundler.rubygems.org > Accept: / > < HTTP/1.1 413 Request Entity Too Large
    < Content-Type: application/octet-stream
    < Server: thin 1.5.0 codename Knife
    < X-Frame-Options: sameorigin
    < X-Xss-Protection: 1; mode=block
    < Content-Length: 0
    < Connection: keep-alive
    <
  • Connection #0 to host bundler.rubygems.org left intact
  • Closing connection #0

Any ideas on how to resolve this? It seems like shortening the list of gems solves the problem, but that seems like a bit of a hack (and I think I would have to modify the Gemfile that is being used in this installation to do so). Thanks in advance for any help.

Chris

  1. Support Staff 1 Posted by Luis Lavena on 13 Feb, 2013 04:27 PM

    Luis Lavena's Avatar

    Hello,

    Have you tried asking this to Bundler developers?

    https://github.com/carlhuda/bundler/issues

    I think this should be requested at Bundler itself instead of rubygems.org

  2. 2 Posted by Chris Hart on 13 Feb, 2013 04:33 PM

    Chris Hart's Avatar

    I have based on your suggestion, but I wanted to open it here as well because a 413 is sometimes caused by (or can at least be corrected by) changing the web server configuration...

  3. Support Staff 3 Posted by Luis Lavena on 13 Feb, 2013 04:38 PM

    Luis Lavena's Avatar

    That is correct.

    Due recent rubygems.org migration the server configuration got changed
    and is not as permissive as before.

    That is why I believe Bundler should generate smaller URLs

    Perhaps Evan Phoenix can comment on this?

  4. 4 Posted by Chris Hart on 13 Feb, 2013 06:08 PM

    Chris Hart's Avatar

    Hey folks, thanks for the responses. It turns out the problem was actually due to something else unrelated. A gem that previously had worked was yanked, and I incorrectly attributed the failure to install it as being related to this issue. Both bundler and rubygems is fine. Thanks for being so responsive, sorry to waste your time!

  5. Support Staff 5 Posted by Nick Quaranto on 20 Feb, 2013 01:45 AM

    Nick Quaranto's Avatar

    This should be fixed now.

  6. Nick Quaranto closed this discussion on 20 Feb, 2013 01:45 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac