No subject

Vasily Vasinov's Avatar

Vasily Vasinov

13 Dec, 2012 12:17 AM

I pushed two versions of my gem today: https://rubygems.org/gems/almanac

gem query -r almanac -n almanac returns:

*** REMOTE GEMS ***
almanac (0.7.2)

Which is fine. The problem shows up if I try to update gems locally by adding this to the Gemfile: gem "almanac", ">= 0.7.2"

After running bundle update the following is returned:

Fetching gem metadata from https://rubygems.org/........
Fetching gem metadata from https://rubygems.org/..
Could not find gem 'almanac (>= 0.7.2) ruby' in the gems available on this machine.

I accidentally canceled gem push for version 0.7.0 this morning, which broke things (I couldn't even force the gem installation), so I yanked it. Forcing gem install works now gem install almanac -v 0.7.2. I tried completely reinstalling all gems and it didn't work.

Please advise.

  1. 1 Posted by Vasily Vasinov on 13 Dec, 2012 01:05 AM

    Vasily Vasinov's Avatar

    I was not clear in the last paragraph: even though gem install almanac -v 0.7.2 works, it's not enough, because if I, say, deploy to Heroku, bundle is used and it doesn't work with any versions of the gem that are older than 0.6.1

  2. 2 Posted by Vasily Vasinov on 13 Dec, 2012 04:57 AM

    Vasily Vasinov's Avatar

    Hmm... It seems like the issue fixed itself and I am able to install the latest version via bundle update both on my local machine and Heroku instance.

  3. Support Staff 3 Posted by Eric Hodel on 13 Dec, 2012 06:59 PM

    Eric Hodel's Avatar

     

  4. Eric Hodel closed this discussion on 13 Dec, 2012 06:59 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac