Puppet 3.0.0 gem still unavailable

Moses's Avatar


30 Sep, 2012 06:03 PM

This is in reference to http://help.rubygems.org/discussions/problems/1349-mirror-seems-out....

This is still an issue today. For example, attempting to download the gem directly via http://production.cf.rubygems.org/gems/puppet-3.0.0.gem results in an AWS error. Attempting to install via gem install puppet still returns
ERROR: Could not find a valid gem 'puppet' (>= 0) in any repository
ERROR: Possible alternatives: puppet

  1. 1 Posted by Steve on 01 Oct, 2012 12:50 AM

    Steve's Avatar

    This comment was split into a new discussion: Cocaine gem not available

    Also seeing this with cocaine:

    Gem::RemoteFetcher::FetchError: bad response Not Found 404 (http://production.cf.rubygems.org/gems/cocaine-0.3.2.gem)
    An error occurred while installing cocaine (0.3.2), and Bundler cannot continue.
    Make sure that gem install cocaine -v '0.3.2' succeeds before bundling.

    The specified key does not exist.


  2. 2 Posted by Moses on 01 Oct, 2012 02:12 AM

    Moses's Avatar


    I'm no longer experiencing this issue with Puppet, so I think this specific ticket can be closed. If you're still experiencing the issue with cocaine, you may want to open a separate ticket?

  3. Support Staff 3 Posted by Nick Quaranto on 10 Oct, 2012 12:40 AM

    Nick Quaranto's Avatar

    Looks like this was fixed, lots of AWS issues :(

  4. Nick Quaranto closed this discussion on 10 Oct, 2012 12:40 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac