gem install hanging

blazar's Avatar

blazar

19 Apr, 2010 09:31 PM

Since Friday I have had major issues installing gems (ruby 1.8.7 p249, rubygems 1.3.6, OS X 10.5.latest). Today I started running gem install with -V and am finding that the hang happens when trying to retrieve a file from s3. For example:

gem install rails -V
GET http://rubygems.org/latest_specs.4.8.gz
302 Found
GET http://production.s3.rubygems.org/latest_specs.4.8.gz
200 OK
GET http://rubygems.org/specs.4.8.gz
302 Found
GET http://production.s3.rubygems.org/specs.4.8.gz

Could really use some assistance with this.

Thanks!

  1. Support Staff 1 Posted by Nick Quaranto on 23 Apr, 2010 05:08 AM

    Nick Quaranto's Avatar

    Hi there,

    Sorry about the delay here!

    Are you behind a firewall or NAT? We've heard a lot of reports of this but really can't track it down.

  2. 2 Posted by tbecker on 13 Jul, 2010 10:30 AM

    tbecker's Avatar

    I have similar issues.

    I have problems on my Macbook Pro with installing gems.

    I am on 10.6.4 OS, Ruby 1.8.7 Patchlevel 249 and gem 1.3.7.

    I am trying to install a gem, I use the verbose option.

    This is my output:
    GET http://rubygems.org/latest_specs.4.8.gz
    302 Moved Temporarily
    GET http://production.s3.rubygems.org/latest_specs.4.8.gz

    Here the installation stops. I can download the file in the browser okay, but the download to local does not seem to work. I am not behind a firewall or NAT:

    Any pointers?

    Thanks

    Torsten

  3. 3 Posted by tbecker on 15 Jul, 2010 02:53 PM

    tbecker's Avatar

    Hi,
    I solved my problems. The main problem was, that I had updated Ruby before updating Mac OS. Therefore, there were two ruby installations on my machine which conflicted somewhat. I removed the non Mac OS version. Now everything works fine. All problems are solved.
    Torsten

  4. Nick Quaranto closed this discussion on 17 Jul, 2010 08:41 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM
18 Oct, 2014 08:39 PM
16 Oct, 2014 12:41 PM
06 Oct, 2014 02:30 PM