Meaningless version error message

Andrew France's Avatar

Andrew France

28 Jan, 2010 01:25 PM

Hi,

I tried a gem update today and among many of the problems was that rack was updated to 1.1.0 and caused Rails apps to fail with the following error:
RuntimeError: RubyGem version error: rack(0.9.1 not ~> 1.0.1)

I really don't think most people are going to understand the very particular definition of "~>" that RubyGems uses. I had to go off and search through the RubyGems guides to find any references to it. Perhaps the message could be replaced with an appropriate phrase?

Although I guess the ideal behaviour would be to satisfy the ActionPack dependencies?

gem --version = 1.3.5

Regards,
Andrew

  1. Support Staff 1 Posted by Eric Hodel on 28 Jan, 2010 10:09 PM

    Eric Hodel's Avatar

    It's explained well in http://docs.rubygems.org/read/chapter/7 as RubyGems' rational versioning policy.

    If you can come up with an appropriate phrase, please file a bug in the rubygems tracker.

  2. Eric Hodel closed this discussion on 28 Jan, 2010 10:09 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM
18 Oct, 2014 08:39 PM
16 Oct, 2014 12:41 PM
06 Oct, 2014 02:30 PM