Particular gem on particular CloudFront domain name

ryan's Avatar

ryan

09 May, 2012 08:43 PM

I'm getting 403 Forbidden errors on a few select gems:

  • trinidad_jars-1.0.2.gem
  • trinidad_jars-1.0.3.gem

(I haven't tried others too extensively, but the rest of my Gemfile is accessible just fine)

I've determined that I only see this issue at work, where production.cf.rubygems.org resolves to d2chzxaqi4y7f8.ind6.cloudfront.net, but if I log in to any of a few remote servers (which resolve the URL to the d2chzxaqi4y7f8.cloudfront.net host), it works fine.

In the interest of full disclosure, I'm on a corporate network. That said, I'm on the DMZ'ed wireless network, using custom DNS servers (Google's and Level3). I can't say for certain that there isn't some strange rewrite that's happening to do some caching, etc, but if you could help I'd really appreciate it.

  1. 1 Posted by ryan on 09 May, 2012 08:48 PM

    ryan's Avatar

    I also see this when I am pointed to the d2chzxaqi4y7f8.ewr2.cloudfront.net. domain name.

    ; <<>> DiG 9.7.0-P1 <<>> production.cf.rubygems.org
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 36355
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 10, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;production.cf.rubygems.org.  IN  A
    
    ;; ANSWER SECTION:
    production.cf.rubygems.org. 3197 IN CNAME d2chzxaqi4y7f8.cloudfront.net.
    d2chzxaqi4y7f8.cloudfront.net. 46 IN  CNAME d2chzxaqi4y7f8.ewr2.cloudfront.net.
    d2chzxaqi4y7f8.ewr2.cloudfront.net. 46 IN A 216.137.41.194
    d2chzxaqi4y7f8.ewr2.cloudfront.net. 46 IN A 216.137.41.233
    d2chzxaqi4y7f8.ewr2.cloudfront.net. 46 IN A 216.137.41.11
    d2chzxaqi4y7f8.ewr2.cloudfront.net. 46 IN A 216.137.41.135
    d2chzxaqi4y7f8.ewr2.cloudfront.net. 46 IN A 216.137.41.201
    d2chzxaqi4y7f8.ewr2.cloudfront.net. 46 IN A 216.137.41.120
    d2chzxaqi4y7f8.ewr2.cloudfront.net. 46 IN A 216.137.41.16
    d2chzxaqi4y7f8.ewr2.cloudfront.net. 46 IN A 216.137.41.213
    
    ;; Query time: 2509 msec
    ;; SERVER: 10.0.2.3#53(10.0.2.3)
    ;; WHEN: Wed May  9 22:46:32 2012
    ;; MSG SIZE  rcvd: 249
    
  2. 2 Posted by ryan on 09 May, 2012 08:58 PM

    ryan's Avatar

    After further research, I determined that a HEAD request to the problematic edge servers results in a 200 OK response, but a GET causes a 403 after approximately a 30-second delay.

  3. Support Staff 3 Posted by Nick Quaranto on 04 Aug, 2012 05:38 PM

    Nick Quaranto's Avatar

    Catching up on issues here.

    Ugh...is this still happening?

  4. 4 Posted by ryan on 06 Sep, 2012 04:06 PM

    ryan's Avatar

    Hey Nick,

    Sorry for the delay. I was only just now able to test this out again, as I'm not in that office regularly anymore. I couldn't reproduce this problem again, so I'd say it's probably remedied itself.

  5. ryan closed this discussion on 06 Sep, 2012 04:08 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM
18 Oct, 2014 08:39 PM
16 Oct, 2014 12:41 PM
06 Oct, 2014 02:30 PM