Gem Install problems. Cannot get http://cachefly.mirrors.rubygems.org

Alfred's Avatar

Alfred

23 Apr, 2012 12:06 AM

I'cannot install some gems like rack-1.4.1.gem, and activemodel-3.2.2.gem. When i try to get it from the brouser, like this: http://cachefly.mirrors.rubygems.org/gems/activemodel-3.2.2.gem, I get - "connection timeout". And "ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError)

Errno::ETIMEDOUT: A connection attempt failed because the co.." from command line.
  1. 1 Posted by Alfred on 30 Apr, 2012 05:04 AM

    Alfred's Avatar

    any suggestions?

  2. 2 Posted by Hardik on 01 May, 2012 05:54 AM

    Hardik's Avatar

    +1

  3. 3 Posted by Alfred on 05 May, 2012 06:33 AM

    Alfred's Avatar

    I found something. But still need help.
    When i'm trying to get cachefly.mirrors.rubygems.org by onlineservises like this(http://www.websitenotworking.com/cachefly.mirrors.rubygems.org) it's ok (the getting ip, in this case is 205.234.175.175, when i'm try to ping this ip, it's work fine). I try to get the ip of the cachefly.mirrors.rubygems.org, here http://www.selfseo.com/find_ip_address_of_a_website.php, and it's show another ip - 140.99.93.175. I cant get the answer when pinging this.

  4. 4 Posted by mkay on 09 May, 2012 03:02 PM

    mkay's Avatar

    have the same. from one localization a can connect and download gems from another i cant. this is some problems with cdn a think

  5. 5 Posted by Tushar on 12 May, 2012 03:49 PM

    Tushar's Avatar

    Not working for me too since the morning. Trying to download sass, tried both command line and download manager.
    Command line throws "too many connection resets" error and Download manager times out :|

  6. 6 Posted by hifi on 15 May, 2012 06:18 AM

    hifi's Avatar

    facing same issue when trying to install rails using

    gem install rails

    ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError)

    too many connection resets (http://cachefly.mirrors.rubygems.org/gems/rack-cache-1.2.gem)
    

    is this site working ??

  7. 7 Posted by sieudang2002 on 15 May, 2012 05:45 PM

    sieudang2002's Avatar

    hi all,
    I am in Vietnam, I got the same error when I try to install "sudo gem install rails" on my macbook pro.
    Well, the main reason is http://cachefly.mirrors.rubygems.org host, this host's very slow, sometimes it was stuck, so gem sent many connection but it got no data, then gem reset conection then send new connection again, and nothing got ==> FetchError.
    You need speed up your internet, this means you should find a place where have a highly speed internet international, and try again. It shoulds work.
    I did it, I've used 3G usb to install it.
    Good luck
    sieudang2002

  8. 8 Posted by Alfred on 16 May, 2012 12:01 AM

    Alfred's Avatar

    So, i need to change my internet provider to install gems, by my speed is 1mbps, is it too slow?

  9. Support Staff 9 Posted by Evan Phoenix on 16 May, 2012 03:23 AM

    Evan Phoenix's Avatar

    I've disabled cachefly, please try your requests again.

  10. 10 Posted by Alfred on 16 May, 2012 04:30 AM

    Alfred's Avatar

    Now, it's working well, thanks=)

  11. 11 Posted by sieudang2002 on 16 May, 2012 09:38 AM

    sieudang2002's Avatar

    hi dude,
    glad to heard you disabled cachefly.
    I tried again, installing very fast.

    Many thanks

  12. Luis Lavena closed this discussion on 11 Jun, 2012 05:36 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM
18 Oct, 2014 08:39 PM
16 Oct, 2014 12:41 PM
06 Oct, 2014 02:30 PM