Problems installing gems

madhavan.kumar's Avatar

madhavan.kumar

08 Oct, 2013 04:49 PM

I have searched various forums and tried different workarounds...so far nothing seems to work. I am trying to install gems but they error out as below:

C:\>gem install rubyzip
ERROR: Could not find a valid gem 'rubyzip' (>= 0), here is why:
          Unable to download data from https://rubygems.org/ - SSL_connect retur
ned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (
https://s3.amazonaws.com/production.s3.rubygems.org/latest_specs.4.8.gz)
ERROR: While executing gem ... (TypeError)
    can't modify frozen object

I tried to add to the source as below:
C:\Users\kumam2>gem sources -a http://s3.amazonaws.com/production.s3.rubygems.org
Error fetching http://s3.amazonaws.com/production.s3.rubygems.org:
        bad response Not Found 404 (http://s3.amazonaws.com/specs.4.8.gz)

  1. Support Staff 2 Posted by Luis Lavena on 08 Oct, 2013 10:41 PM

    Luis Lavena's Avatar

    Hello,

    There are a few other threads here (help.rubygems.org) and bugs reports on
    GitHub, like this one:

    https://github.com/rubygems/rubygems/issues/671

    Most likely there will be an updated version of RubyGems shortly that will
    correct these issues.

  2. 3 Posted by madhavan.kumar on 10 Oct, 2013 09:22 PM

    madhavan.kumar's Avatar

    Thank you Luis. I did refer to the the link that you provided. Is there an updated version of rubygems?

    I did try gem update --system
    but got the message:
    Latest version currently installed. Aborting.

    Regards,
    Madhavan

  3. Support Staff 4 Posted by Luis Lavena on 10 Oct, 2013 09:26 PM

    Luis Lavena's Avatar

    Please take a look on how to manually update RubyGems if it cannot be
    automatically updated:

    http://rubygems.org/pages/download

  4. 5 Posted by madhavan.kumar on 11 Oct, 2013 02:04 PM

    madhavan.kumar's Avatar

    Thank you Luis. This update of Rubygems resolved my problems. I am now able to install the gems without any issues.

    Regards,
    Madhavan.

  5. madhavan.kumar closed this discussion on 11 Oct, 2013 07:28 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

29 Aug, 2014 06:23 PM
28 Aug, 2014 07:18 PM
27 Aug, 2014 12:03 PM
26 Aug, 2014 07:09 PM
26 Aug, 2014 07:07 PM